Блог им. 63vova

2020 03 15 Пример торговой системы на базе индикаторов по открытым позициям фьючерса РТС

Друг задал вопрос: ”Какой сейчас сигнал выдают индикаторы?”.

С учетом использования в работе большого количества индикаторов (смотрим предыдущие посты) ответ может быть иногда немного длительным, особенно в момент длительного флета, как в феврале месяце.

С целью отказа от построения линий тренда, предлагаю в качестве варианта применение мувингов, то есть использовать функцию срзнач().

А далее, как всегда, проверка условий пересечения индикатора и мувингов)))

Нюансы, как всегда, есть.. .  Например, перепады в период экспирации.

Для примера на листе «Сигналы ТС» для индикатора Poza построены два мувинга.

По аналогии строим мувинги и для других индикаторов.

Логика торговой системы (в рамках значений оси Х):

  1. 100 – хороший сигнал лонг;
  2. 75 — попытка открытия лонг, если до этого был шорт. Или сокращение части позиций, если до этого был лонг;
  3. 50 – флет;
  4. 25 — попытка открытия шорт, если до этого был лонг. Или сокращение части позиций, если до этого был шорт;
  5. 0 – хороший сигнал шорт.


Формула варианта сигналов простейшей торговой системы (для ячейка R30 на листе «data):

=ЕСЛИ(И(C30>=Q30; Q30>P30); 100;
   ЕСЛИ(ИЛИ(И(C30<=Q30; Q30>P30; C30>C29);  И(C30>Q30;Q30<P30; C30>P30;P30>P29 )); 75;
   ЕСЛИ(И(C30<=Q30;Q30<P30); 0;
   ЕСЛИ(ИЛИ(И(C30>Q30;Q30<P30; C30<C29); И(C30<Q30;Q30>P30; C30<P30; P30<P29 ));25;
   50 ) ) ) )

 PS:

1. Обновляемые диаграммы динамики открытых позиций фьючерса RTS в Excel-файле можно скачать по одному и тому же адресу    yadi.sk/i/wXOQ8w9lB70FBg

2. Для просмотра Excel-файла можно использовать бесплатный офис LibreOffice.

2020 03 15  Пример торговой системы на базе индикаторов по открытым позициям фьючерса РТС


8 комментариев
Данные по открытым позициям руками вводите?
avatar
panikbull, НЕТ!  Есть макрос! Получаю сразу все фьючи ))) Могу дать ссылку… . 
avatar
Vova Privalov, буду благодарен!
avatar
Vova Privalov, а мне можно? 
avatar

теги блога Vova Privalov

....все тэги



UPDONW