Блог им. RomanF79

Excel! Need your help for visual basic ...

Excel! Need your help for visual basic ...


Сформировал отчет в котором прикрутил следующее:

Private Sub Worksheet_Change(ByVal Target As Range)
For Each cell In Target
If Not Intersect(cell, Range(«A2:A20000»)) Is Nothing Then
With cell.Offset(0, 4)
.Value = Now
.EntireColumn.AutoFit
End With
End If
Next cell
End Sub

Как учесть удаление строчек (сдвиг всех ячеек) и очистку ячеек (если значение стало «0» то дата не фиксируется)?

Заранее спасибо!

It is not Visual Basic…
Сергей Гаврилов, VBA же.
Гденьги ☭, VBA и VB две очень большие разницы…  
поясните словами, что хотите сделать
avatar

Андрей К

Андрей К, Нужно достичь следующего… при внесении данных в строчку (учитываем определенную ячейку, то есть столбец с ячейками «А» в «D» автоматом проставляется дата занесения данных в «А». Этого я достиг, но не работает удаление строчек и обнуление данных… даты в этих случаях обновляются. кстати при упорядочивание, дата не изменяется это +.
Роман Франтовский, я вот, например, ни хрена не понял из Вашего объяснения, хотя, наверно мог бы помочь…
Сергей Гаврилов, По простому… если вношу данные, то в последней ячейке фиксируется время и дата внесения.

Сергей Гаврилов, началось все с простого ...=ЕСЛИ(A2>0; (СЕГОДНЯ());"")
В екселе есть следующая возможность -включить запись макроса и начать делать что то «руками» он интерпретирует это в код, а после нужные фрагменты кода вы уже можете использовать как образец.
avatar

Black Swan

Black Swan, судя по его коду, автор давно перерос самописные макросы. Но что он хочет — непонятно. 
If Not Intersect(cell, Range(«A2:A20000»)) Is Nothing And Len(cell) <>0 Then
Добавил проверку на пустоту ячейки
Сергей Гаврилов, не собирается все вместе
Роман Франтовский, а чего пишет?


Сергей Гаврилов, 

Сергей Гаврилов, кажется так заработает ...

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
Intersect(Columns(«A»), Target(1)).Offset(, 4) = Now
End Sub

 

Сергей Гаврилов, сорри с просонья заминусил, не хотел…
avatar

massimo

Я один считаю что эксель и вба параша, или его теперь можно отучить пересчитывать миллион триллионов раз одно и тоже, когда эксель закачал 500+ гб оперативы и висел часа полтора, а потом матлаб тоже самое посчитал за 0,02 сек я решил что он прикалывается
avatar

_____Life_Line


Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.

Залогиниться

Зарегистрироваться
....все тэги
Регистрация
UPDONW