<HELP> for explanation

Ответы на вопросы

Ответы на вопросы | Как в эксель сделать формулу: Есть три столбца: А, В и С (и Критерий1 и Критерий2) Если А1 = Кр.1 или Кр.2, то С1=В1 Если не найдено, то искать до конца столбца А (пока не найдется один из критерие

Как в эксель сделать формулу: Есть три столбца: А, В и С (и Критерий1 и Критерий2) Если А1 = Кр.1 или Кр.2, то С1=В1 Если не найдено, то искать до конца столбца А (пока не найдется один из критерие
 

а картинкой можно сделать?
Григорий,

Вот смотри — есть левый столбец список и два критерия «104АА» и «107АТ»
Нужно что бы был поиск этих критериев в левом столбике — и если допустим находится «104АА» или «107АТ», то значение из столбика В переписывалось в столбец С
(«104АА» и «107АТ» будут иметь одинаковый параметр в столбце В (в этом примере он равняется 5, но поиск должен быть именно по двум критериям т.к. параметр в колонке В будет одинаковым, а вот какого-то критерия может не быть в списке А)
ruscash, Точно не помню, но по-моему функция «ВПР» должна помочь. Попробуйте ее скомбинировав с «ЕСЛИ».
Если я правильно понял Ваш вопрос, то это можно сделать, если через столбец С провести, например, вот такую формулу:
=ЕСЛИ(ИЛИ(A1=$D$1,A1=$E$1),B1,0)
Ну как бы, ты пробовал? у меня несчтает — так понял ошибку выдает т.к. в формулу ЕСЛИ в первой области для воода не определяется это условие (ИЛИ(A1=$D$1,A1=$E$1)
ruscash, точка с запятой нужна, а не запятая
dt-msk, dt-msk, так — а как сделать — что бы не нужно было пересчитывать каждую строку (растягивать на каждый столбец)? — а он самостоятельно список перебирал и в эту ячейку вставлял найденное значение?
ruscash, тогда следующим образом:
=ЕСЛИОШИБКА(ИНДЕКС(B:B; МИН(ЕСЛИОШИБКА(ПОИСКПОЗ(E1;A:A;0);10^36); ЕСЛИОШИБКА(ПОИСКПОЗ(F1;A:A;0);10^36)));«нет»)
dt-msk, Спасибо — вроде заработало как надо )))))

*Только если копировать данную формулу в эксель — нужно вместо кавычек «нет» поставить «нет»)
ruscash, да, кавычки всегда должны быть другие. Это смарт-лаб подменяет.
для каждой ячейки в стб С. ВПР
askit.ru/custom/vba_office/vba_office_plan.htm
www.firststeps.ru/vba/excel/vbaexcel1.html

ну наверно если есть такие вопросы — уже надо учиться.
а вообще с такими вопросами не сюда.
но макросы знать надо ))

avatar

FXFX

alt+f11 -> в рабочий лист добавить макрос
sub aaa
dim i as integer
do
i=i+1
if range(«A»&i) = [D1] or range(«A»&i) = [E1] then
range(«A»&i).offset(0,2) = range(«A»&i).offset(0,1)
end if
loop until range(«A»&i+1) = empty
end sub
avatar

v3Rtex

v3Rtex, а макросы убыстряют работу екселя если в него DDE данные поступают?
ruscash, это как понять? по крайней мере не тормозят процесс, но это зависит от массива обрабатываемых данных
v3Rtex, у меня ноут начинает тормозить если много таблиц начинаю выводить в ексель — приходится оставлять только самое важное
или по тупому ))
Sub Ìàêðîñ1()
Dim Kr1 As String
Dim Kr2 As String
Dim i As Long

Kr1 = Cells(1, 4)
Kr2 = Cells(1, 5)


For i = 1 To 100

If Cells(i, 1) = Kr1 Then
Cells(i, 3) = Cells(i, 2)
End If

Next i

For i = 1 To 100

If Cells(i, 1) = Kr2 Then
Cells(i, 3) = Cells(i, 2)
End If

Next i

End Sub
avatar

FXFX

Господин хоорший, это то что тебе нужно

Джон Уокенбах Excel 2013 профессиональное программирование на VBA

avatar

FXFX

dt-msk, а что такое «10^36»?
ruscash, это максимально возможное значение для критерия, если он отсутствует
ruscash, ошибка у меня там, не F1, а D1 надо
заплатите программисту 1000 руб, он за 15 мин накидает. Сами осваивать будете дольше. и дороже.

Только зарегистрированные и авторизованные пользователи могут оставлять комментарии.

Залогиниться

Зарегистрироваться
....все тэги
Регистрация
UP